Skip to content

Requirements

Requirements

Arista EOS version

  • EOS 4.21.8M or later
  • Roles validated with eAPI transport -> ansible_connection: httpapi

Arista Cloudvision

Cloudvision instance must be supported by Cloudvision ansible collection

Python

  • Python 3.6.8 or later

Supported Ansible Versions

  • ansible 2.9.2 or later

Additional Python Libraries required

Python requirements installation

In a shell, run following command:

$ pip3 install -r ansible_collections/arista/cvp/requirements.txt
netaddr>=0.7.19
Jinja2>=2.10.3
paramiko>=2.7.1
requests>=2.22.0
cvprac>=1.0.7
jsonschema>=3.2.0
treelib>=1.5.5

Depending of your operating system settings, pip3 might be replaced by pip.

Ansible runner requirements

A optional docker container is available with all the requirements already installed. To use this container, Docker must be installed on your ansible runner.

To install Docker on your system, you can refer to the following page: Docker installation step by step

Or if you prefer you can run this oneLiner installation script:

$ curl -fsSL get.docker.com | sh

In addition, docker-compose should be considered to run a stack of containers: https://docs.docker.com/compose/install/


Last update: April 28, 2021


Back to top